How to run this? I get exception error

Oct 19, 2010 at 11:17 AM

I downloaded the sample website, and i made it run under win2008 on .net 3.5 and 4.0; then on win2003 on .net 3.5, but i get this exception error when running the /GateKeeper/GateKeeperManager.aspx

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 54:     {
Line 55:         List<httpBL> entries = new List<httpBL>();
Line 56:         foreach (XmlNode node in Utils.xmlHttpBLList.SelectSingleNode("/gatekeeper/httpbl").ChildNodes)
Line 57:         {
Line 58:             httpBL entry = new httpBL();


Source File: xxx\GaKeeper\User Controls\HttpBL.ascx.cs    Line: 56

 

What i am doing wrong? How to run this?

Coordinator
Oct 19, 2010 at 8:18 PM

It sounds like I didn’t check correctly for the existence of the httpbl node in the configuration file.  Make sure you have a node in your XML document called httpbl.

Chris

From: Magnetic_dud [mailto:notifications@codeplex.com]
Sent: Tuesday, October 19, 2010 7:18 AM
To: chris@dscoduc.com
Subject: How to run this? I get exception error [GateKeeper:231458]

From: Magnetic_dud

I downloaded the sample website, and i made it run under win2008 on .net 3.5 and 4.0; then on win2003 on .net 3.5, but i get this exception error when running the /GateKeeper/GateKeeperManager.aspx

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 54:     {
Line 55:         List<httpBL> entries = new List<httpBL>();
Line 56:         foreach (XmlNode node in Utils.xmlHttpBLList.SelectSingleNode("/gatekeeper/httpbl").ChildNodes)
Line 57:         {
Line 58:             httpBL entry = new httpBL();


Source File: xxx\GaKeeper\User Controls\HttpBL.ascx.cs Line: 56

What i am doing wrong? How to run this?

Read the full discussion online.

To add a post to this discussion, reply to this email (GateKeeper@discussions.codeplex.com)

To start a new discussion for this project, email GateKeeper@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Oct 19, 2010 at 9:45 PM

there is no httpbl.xml in the directory

how to create that? i could not find it in any packages

Mar 4, 2011 at 1:48 PM

Hey Magnetic dud or Chris, I know this is somewhat of an old thread that I stumbled upon but I'm having the same issue with the project. I was wondering if the issue was ever resolved. I'm a bit of a newb and for the life of me, I can't trace the problem. This is really a great project with a lot of promise and I would love to get it working on our site. If either of you could get back to me on a solution for this I would truly appreciate the help.

Mar 4, 2011 at 1:52 PM

I am still not able to fix the problem

I "fixed" the problem by using linux+apache

Mar 4, 2011 at 2:12 PM
Magnetic_dud wrote:

I am still not able to fix the problem

I "fixed" the problem by using linux+apache

Alright, thanks for getting back to me so quickly. Unfortunately, I don't have the option of going to a Linux box, so I'll continue plugging along. If I find something, I'll let you know.